Confluence fails to start and throws ‘MySQL session isolation level ‘REPEATABLE-READ’ is no longer supported’ error or Your database must use ‘READ-COMMITTED’ as the default isolation level.

If you found

Confluence fails to start and throws ‘MySQL session isolation level ‘REPEATABLE-READ’ is no longer supported’ error

or

Your database must use ‘READ-COMMITTED’ as the default isolation level.

Like :

 

Set the global transaction isolation level to READ-COMMITTED. You can do this by configuring your MySQL server’s settings by editing MySQL’s my.cnf file (often named my.ini on Windows operating systems). Locate the [mysqld] section in the file and add/modify the following parameter:

In my Case i found my file :

/etc/mysql/my.cnf

and add content like :

[mysqld]
default-storage-engine=INNODB
character_set_server=utf8mb4
innodb_default_row_format=DYNAMIC
innodb_large_prefix=ON
innodb_file_format=Barracuda
innodb_log_file_size=2G
sql_mode = NO_AUTO_VALUE_ON_ZERO
transaction-isolation=READ-COMMITTED

When create database use follwing code (As Database Character set and storage issue)

Login as Root USER
run >>
mysql
then run >>
CREATE DATABASE <database-name> CHARACTER SET utf8 COLLATE utf8_bin;
then run >> if no password defined
GRANT ALL PRIVILEGES ON <database-name>.* TO ‘<confluenceuser>’@’localhost’ IDENTIFIED BY ‘<password>’;
then run >> if no password already defined
GRANT ALL PRIVILEGES ON confluencedb.* TO ‘equaltrue’@’localhost’;
then run >>
FLUSH PRIVILEGES;

Was this article helpful?

Leave A Comment?

You must be logged in to post a comment.